首页运维零件 › 找不到DHCP服务器将无法为新设备自动分配IP地址,vns威尼斯城官网登入:Cavium以13.6亿美元收购网络厂商QLogic

找不到DHCP服务器将无法为新设备自动分配IP地址,vns威尼斯城官网登入:Cavium以13.6亿美元收购网络厂商QLogic

升级网卡固件以及驱动的时机

网卡绑定如何影响虚拟机性能

  目前很多最新版本的常用操作系统都提供免费的Initiator软件,建立一个存储系统除了存储设备本身外,基本上不需要投入更多的资金来,因此在三种系统连接方式中其建设成本是最低的。

图 4-6 原网卡仅自动勾选"Hyper-V 可扩展的虚拟交换机"

由此可以发现,作为物理网卡的"VM"变成了"Hyper-V
可扩展的虚拟交换机",而新创建的"vEthernet(VM虚拟交换机)"则成为一张虚拟网卡,为宿主机的通信和管理服务。接下来继续将另外一张网卡创建新的虚拟交换机。在创建虚拟交换机时,可以勾选"启用单根

I/O 虚拟化(SR-IOV)",如图 4-7 所示。

vns威尼斯城官网登入 1

图 4-7
新创建虚拟交换机可勾选 SR-IOV

SR-IOV:该技术全称为 Single Root IO Virtrualiztion,通 过 SR-IOV,一个
PCIe 设备不仅可以导出多个 PCI 物理功能,还可以导出共享该 I/O
设备上的资源的一组虚拟功能,每个虚机可占用一个或多个虚拟
PCIe,网络传输无需 Hypervisor
的协调干预,降低了传输中的损耗和开销,因此传输速度可以显著提升。该技术需要网卡的硬件支持,如果读者购买的服务器网卡支持
SR-IOV 功能,则可以在创建虚拟交换机时开启这项功能。

将两张网卡均创建虚拟交换机后,"网络连接"的信息如图 4-8 所示。

由于我是用workstation来实验,所以下面Public网卡显示图标不对

vns威尼斯城官网登入 2

晓苏是我以前的同事,现在任职Cavium公司技术经理。

选择正确的网络技术

  因此iSCSI存储连接的交换机一般都用作iSCSI存储内的控制器,而不是iSCSI存储与主机之间网络连接设备。

4.5 小结

本章为大家介绍了 Hyper-V
的基础网络配置,通过创建虚拟交换机,可以为接下来虚拟机和物理网络的通信打下基础。VLAN
的配置和应用则可以将物理网络的 VLAN
特性带到虚拟环境中。而带宽管理和相应的网络高级功能能够为企业的虚拟化运维带来更具有颗粒度的管理。NIC
组合是一项从 Windows Server 2012 中带来的新功能,通过 NIC
组合,我们能够从网络层面为虚拟机带来高可用性,其实现简单,效果明显,同时基础配置无需高级交换机的配合,因此可以说,这是一项无论如何也值得一试的功能。

 

vSphere
原本就支持InfiniBand网络,在2017年3月的文章vSphere 6.5 with
RoCE (RDMA over Converged Ethernet)and Certification Suite 中,已经开始了网卡认证工作。vSphere
一旦开始支持RDMA网络,vSAN
就会很快实现了。希望到那个时候,我们可以再横向比较一下vSAN在RDMA网络和普通TCP/IP
网络之间的区别。

首先,确认升级后是否能真正解决问题。如果不是解决特定的问题,那么不建议升级。例如,如果固件升级能解决特定网卡不能启用TOE的bug,为了启用TOE并提升网络性能,升级固件可能很有必要。与之相反,如果固件升级修复了NIC并未使用的一个芯片的bug,反而可以不升级。

首先,确认升级后是否能真正解决问题。如果不是解决特定的问题,那么不建议升级。例如,如果固件升级能解决特定网卡不能启用TOE的bug,为了启用TOE并提升网络性能,升级固件可能很有必要。与之相反,如果固件升级修复了NIC并未使用的一个芯片的bug,反而可以不升级。

  第三种:iSCSI HBA卡连接方式。

图 4-20Hyper-V 修改静态 MAC 地址

除了静态 MAC
地址外,Hyper-V
还提供了以下几种高级功能:

  • DHCP 防护:这是自
    Windows Server 2012
    以来的一项新功能,由于 DHCP 的特性是客户端向
    68 端口(bootps)广播请求配置,服务器向
    67 端口(bootpc)广播回应请求。DHCP
    防护正是基于此理论的一项实践,在为虚拟机开启 DHCP
    防护后,即使该虚拟机安装有 DHCP
    服务端,也无法在局域网内进行广播。可以防止虚拟机中恶意或假冒的用户进行
    DHCP
    欺骗。该功能实现简单,仅勾选选项即可。
  • 路由器保护:此功能有助于保护防范未经授权的路由器等,这个功能可以丢弃来自未经授权的虚拟机所假冒的路由器发出的路由器公告和重定向消息。
  • 受保护的网络:该功能在群集环境中有效,当检测到网卡连接断开后,该虚拟机会自动迁移到其他节点,以保障业务的连贯性,默认情况下该选项被勾选。
  • 端口镜像:在物理服务器配合三层交换机的时代,端口镜像是一种非常有用的功能,它可以帮助网络工程师实时的去分析网络流量,检查网络中存在的问题。来到虚拟化时代,这项功能依然得以保留,只需要将安装了网络监控软件的虚拟机的镜像模式设置为"目标",被监视的虚拟机镜像模式设置为"源"即可。如图
    4-21 所示。

vns威尼斯城官网登入 3 图 4-21Hyper-V 配置端口镜像

---End---

一般来说,管理流量、生产虚拟机流量以及虚拟机迁移任务都可以采用网卡绑定,无论是否适合你的企业都可以启用并配置网卡绑定。一个建议就是在分配负载前建立网卡绑定。另一个很流行的策略就是为客户虚拟机配置单-根I/O虚拟化也就是SR-IOV。

一般来说,管理流量、生产虚拟机流量以及虚拟机迁移任务都可以采用网卡绑定,无论是否适合你的企业都可以启用并配置网卡绑定。一个建议就是在分配负载前建立网卡绑定。另一个很流行的策略就是为客户虚拟机配置单-根I/O虚拟化也就是SR-IOV。

  实际上,我们能在市场上看到的iSCSI存储连接的交换机都不是真正意义上交换机,所谓的iSCSI交换机应该称之为iSCSI协议转换器、或者iSCSI桥接器。一部分端口用来连接主机的iSCSI
HBA卡,另一部分端口用来连接FC存储或SCSI存储,只能实现存储设备与主机之间的FC-iSCSI(或SCSI-iSCSI)协议连接,不能实现iSCSI-iSCSI协议连接,其工作方式完全不同于以太网交换机或FC交换机那样,实现某一个协议内的互联互通。

第 7 步,在弹出的对话框中,点击"其他属性",出现下拉菜单,依次选择成组模式为

"交换机独立"、负载平衡模式为"动态",点击"确定"返回上一层,如图 4-28
所示。

vns威尼斯城官网登入 4 图 4-28NIC 组合配置 7

第 8 步,进入"控制面板"→"网络和共享中心"→"更改适配器设置",可以看到

NIC 组合创建了一张新的虚拟网卡,并且图标异于其他,如图 4-29 所示。

vns威尼斯城官网登入 5 图 4-29NIC 组合配置 8

第 9 步,将 NIC 组合中涉及的两个网卡接上网线,直接插入同一个 VLAN
下的交换机,此时检查该网卡状态,发现其已连接,并且该网卡的带宽速度为两张网卡的叠加。如图
4-30 所示。

需要注意的是,NIC 组合中所涉及的网卡无需配置 IP,在 NIC
组合完成后,所涉及的网卡的 IP 信息均会丢失,并且丢失的 IP 不参与通信。

vns威尼斯城官网登入 6

vns威尼斯城官网登入 7

虚拟化及整合关注于核心的计算资源像处理器以及存储,但是网络I/O资源经常被忽略。网络带宽以及设备配置对确保客户端/服务器高效运行同样很重要——尤其是现在与网络相关的技术在服务器以及网络适配器中不断涌现出来。让我们了解一些能够提升Hyper-V网络性能的技巧。

升级网卡固件以及驱动的时机

  服务器、工作站等主机使用标准的以太网卡,通过以太网线直接与以太网交换机连接,iSCSI存储也通过以太网线连接到以太网交换机上,或直接连接到主机的以太网卡上。在主机上安装Initiator软件。

 

---Begin---

网卡绑定给虚拟服务器带来了很多好处。绑定允许同一台服务器上的多个网卡适配器协同工作以聚合带宽并进行流量的故障切换。例如,可以绑定两个独立的千兆以太网端口以提供两倍带宽,在单个端口发生故障时也能够确保数据正常传输。

然而,硬件、固件、驱动以及操作系统之间的相互关系可能很薄弱且易于出错。有时可能会导致意想不到的新问题或者bug,因此固件以及驱动升级很可能会导致更多的问题。因此不应该盲目升级。

  第一种:以太网卡+initiator软件方式。

图 4-16Hyper-V 带宽限制功能

开启带宽限制后,可以为不同级别的虚拟机提供不同的网络带宽,进而为更重要的业务预留宝贵的带宽,以实现精细化的管控。
带宽限制的实际效果可以在复制文件、上传下载等方面看到直观的效果。

4.3.2
网络硬件加速功能

在虚拟机的网络适配器下,可以进行"硬件加速"的选项配置。

虚拟机队列(VMQ)是一种硬件虚拟化技术,支持
VMQ
的网卡可对传入的帧进行分类,虚拟机队列(VMQ)使得宿主机的网络适配器可以绕过
DMA
数据包,直接参与到特定虚拟机的内存栈中。Windows Server 2012
可用动态的方式将传入网络通讯的处理工作分散到宿主机的处理器上。在网络负载较重时,动态
VMQ
可自动征用更多处理器。在网络负载较轻时,动态 VMQ
会释放这些处理器。值得注意的是,该选项默认是开启的,即使网卡不支持该技术也不会对系统的稳定性造成任何影响。然而如果网卡支持改选项,则可以为网络带来更好的用户体验。如果希望检测网卡是否支持虚拟机队列,可以在"控制面板"→"系统"→"设备管理器"→"网卡"→"属性"→"高级"下进行查找,如果有"VMQ"或"虚拟机队列",即表示支持该功能。如图
4-17 所示,说明 Broadcom BCM5709C
芯片的网卡支持该技术。

vns威尼斯城官网登入 8 图 4-17Hyper-V 带宽限制功能

IPsec
任务卸载同样是一种硬件虚拟化技术,由于很多加密算法是处理器密集型的业务,因此大量的加密数据经过会消耗宿主机的
CPU 资源。IPsec
任务卸载拥有虚拟机卸载加密过程到网卡的能力,从而节省大量的 CPU
运算,,为系统提供更好带宽质量。该技术同样可以通过在"设备管理器"中检测"网卡"的"属性"进行验证,如图
4-18 所示,说明 Intel

82579LM
芯片的网卡支持该技术。使用 IPsec
任务卸载有两个必须的要求:

  • 物理机的网卡必须支持该技术。
  • 虚拟机的操作系统至少是 Windows Server 2008 R2
    或以上版本。

 

vns威尼斯城官网登入 9 图 4-18IPsec 卸载功能

 

单根 I/O
虚拟化不仅可以在创建虚拟交换机时使用,在虚拟机中同样可以使用。同时,这依然是一种需要硬件支持才可以实现的技术,默认情况下该选项不被勾选,只有确信自己的网卡支持该技术,才可以手动勾选该选项,以提升网卡性能,如图
4-19 所示。

vns威尼斯城官网登入 10 图 4-19Hyper-V
网络硬件加速功能。

4.3.3
网络高级功能

虚拟机的网络适配器下,除了"硬件加速"以外,还可以进行"高级功能"的定制。

默认创建的虚拟机的 MAC
地址均为动态地址,动态地址使用方便,但存在一个缺点,在使用 Hyper-V
的高级功能"实时迁移"时,会造成用户的 IP 变动。因此能够手动设置 MAC
地址适用范围更广泛一些。首先关闭虚拟机,然后依次打开虚拟机的"属性"→"网络适配器"→"高级功能",修改
MAC 地址为静态,如图 4-20 所示。

注:我在自己的真实环境真的机器都是开启了静态mac的,这样随便怎么迁移mac不变,ip也不会变了

vns威尼斯城官网登入 11

既然高速以太网网卡可以提升网络带宽来提高性能,那么现在非常火热的以太网RDMA是否也可以应用在vSAN之上呢?众所周知S2D 可以利用iWARP和RoCE 两种以太网RDMA协议。

针对虚拟服务器另一个流行的配置是在传输集群共享卷、iSCSI以及在线迁移流量的网络中启用巨型帧。巨型帧数据包大小是9000或9014个字节,而不是常见的1500字节。通过在每个数据包中传输更多的数据,能够通过更少的数据包完成文件传输,网卡和主机系统的效率会提升。然而巨型帧同样意味着两端所有的网络元素(网卡、交换机以及SAN)都要支持巨型帧。

计算设备通常使用堆栈模式构建:硬件(芯片及连接)在底层,固件(比如BIOS)用于初始化并配置硬件,固件使用驱动与操作系统建立连接。bug以及固件或者驱动的编码技术不过关可能会带来性能问题。这种情况要比你想象的多,往往可以通过升级固件以及驱动来解决该问题。

  由于TOE卡也采用TCP/IP协议,相当于一块高性能的以太网卡,所以第二种方式也可以看做是第一种连接方式的特殊情况。

图 4-30NIC 组合配置 9

成组模式为"交换机独立"、负载平衡模式为"动态"的 NIC
组合,其建立不依赖交换机,任意一台普通交换机均可实现该功能。但这种 NIC
组合只能实现端口冗余和负载均衡,无法实现带宽叠加。

 

4.4.3NIC
组合高级配置最理想的情况是使用交换机的
LACP 功能进行 NIC
组合,当成组模式为"LACP"、负载平衡模式为"地址哈希"时,物理链接的网卡可以额外获得带宽叠加的优势,将服务器定义为文件共享服务器时,该功能的作用会体现的非常明显。

使用 LACP 成组模式,需要满足以下两个条件:

  • 支持 LACP
    的物理交换机,如思科的 2960S 交换机。
  • 一定的前期配置。

第 1 步,使用 telnet 连接思科 2960S 交换机(其他支持 LACP
的思科交换机均可,由于做演示的设备为某生产环境的交换机,因此涂黑做无害处理),进入特权模式后,输入

"show run",查看现有交换机配置,并进行接下来的配置,如图 4-31 所示。

vns威尼斯城官网登入 12 图 4-31NIC 组合高级配置 1

交换机中关于配置 LACP 的部分如下:关键部分以"!"的形式作为注释,供参考。

 

!首先定义 NIC 组合的 Port-channel,每一个 Port-channel 即一个 NIC 组合。

 

!这里定义了 6 组 NIC 组合,均放在
VLAN25 中。 interface Port-channel1 switchport access vlan 10

!

interface Port-channel2 switchport access vlan 25

!

interface Port-channel3 switchport access vlan 25

!

interface Port-channel4

 

switchport access vlan 25

!

interface Port-channel5 switchport access vlan 25

!

interface Port-channel6 switchport access vlan 25

!…………………………

!…………………………

!从第 5 个端口开始配置 NIC 组合,这里定义了 description hv-manager,即指定该端口的注释是"hv-manager"该选项可以方便后期运维的时候对端口的识别。同时该端口配置为 Access VLAN,因此需要加一句 switchport access vlan 25。关于如何确定 NIC 成组,需要将 NIC 组合的成员端口添加一句 channel-group x mode active,其中 x 为 Port-channel,示例中 5 端口和 13 端口即为一个组合;15 和 16 为一个组合。

 

interface GigabitEthernet1/0/5 description hv-manager switchport access vlan 25 spanning-tree portfast channel-group 6 mode active

!

interface GigabitEthernet1/0/6 description HAHV-3-4-0 switchport access vlan 25 spanning-tree portfast

!

interface GigabitEthernet1/0/7 description HAHV-2-4-0 switchport access vlan 10 spanning-tree portfast

!

interface GigabitEthernet1/0/8 description HAHV-1-4-0 switchport access vlan 10 spanning-tree portfast

!

interface GigabitEthernet1/0/9 switchport access vlan 25 spanning-tree portfast

!

interface GigabitEthernet1/0/10

switchport access vlan 25 spanning-tree portfast

!

interface GigabitEthernet1/0/11 switchport access vlan 25 spanning-tree portfast

!

interface GigabitEthernet1/0/12 switchport access vlan 25 spanning-tree portfast

!

interface GigabitEthernet1/0/13 description HAHV-manager-1 switchport access vlan 25 spanning-tree portfast channel-group 6 mode active

!

interface GigabitEthernet1/0/14 switchport access vlan 25 spanning-tree portfast channel-group 4 mode active

!

interface GigabitEthernet1/0/15 description HyperV1 switchport access vlan 25 spanning-tree portfast channel-group 2 mode active

!

interface GigabitEthernet1/0/16 switchport access vlan 25 spanning-tree portfast channel-group 2 mode active

!……………………………………

interface Vlan25 ip address 192.168.x.x 255.255.255.0

!

ip default-gateway 192.168.x.x ip http server ip http secure-server

第 2
步,在配置交换机的过程中只要注意提前定义"Port-channel",并在成组的端口上使用"channel-group
2 mode active"即可。此时可以登录交换机的 web 界面,检查配置情况,如图
4-32 所示。

vns威尼斯城官网登入 13 图 4-32NIC 组合高级配置 2

第 3
步,输入交换机的用户密码后登录到交换机的主界面,此时可以看到交换机的运行健康状况,如图
4-33 所示。

vns威尼斯城官网登入 14 图 4-33NIC 组合高级配置 3

第 4 步,将鼠标移至顶部的虚拟交换机面板处,选择第 8
个端口,可以看到在交换机配置中为该端口写的注释"description
HAHV-1-4-0"的直观体现。在牵扯到较多的宿主机时,配置相应的端口注释是非常重要的一个环节,这可以减少后期维护时误操作的可能性,如图
4-34 所示。

vns威尼斯城官网登入 15 图 4-33NIC 组合高级配置 4

第 5 步,回到 NIC
组合中,修改"成组模式"为"LACP",负载平衡模式为"地址哈希",点击应用。此时会有短暂的网络中断,同时所涉及的网卡接口会出现"已出错
LACP
协商"的错误提示。这种情况是正常的错误提示,此时交换机会与网卡进行协商,如图
4-

34 所示。

vns威尼斯城官网登入 16 图 4-34NIC 组合高级配置 5

第 6 步,等待 5 到 10
秒钟的时间,当交换机与网卡的协商完成后,在"组"对话框中,可以看到该 NIC
组合的状态已经变成了"确定",证明其已经开始生效,如图 4-35
所示。如果同时配置两台这种硬件物理服务器,则这两台服务器之间拷贝数据可以达到带宽叠加的效果。

vns威尼斯城官网登入 17

vns威尼斯城官网登入 18

然而,不建议在iSCSI存储流量中采用网卡绑定。在Windows Server
2012及后续系统中建议优先采用多路径I/O也就是MPIO技术来处理iSCSI存储流量。

其次,应用到生产系统前要在实验环境中进行升级测试。测试有助于提高升级效率,识别潜在的结果并避免在生产环境中出现潜在的混乱局面。

  具有TOE(TCP Offload
Engine)功能的智能以太网卡可以将网络数据流量的处理工作全部转到网卡上的集成硬件中进行,把系统主处理器CPU从忙于协议处理的繁重的内核中断服务中解脱出来,主机只承担TCP/IP控制信息的处理任务。

4.2VLAN 的配置和使用

Hyper-V 虚拟交换机是一个二层交换机,同时其支持 VLAN 技术,通过 VLAN
技术,可以有效的隔绝广播风暴,限制跨 VLAN 之间的相互访问。在宏观上将
Hyper-V 虚拟交换机等同于一台硬件交换机会更容易理解一些,Hyper-V
虚拟交换机所提供的 VLAN 功能和物理交换机所提供的 VLAN 功能完全一致。

4.2.1VLAN
配置

在思科的交换机上,主要有两种 VLAN 类型,分别是 Access VLAN 和 Trunk
VLAN,其中 Acccess VLAN 是基于端口的,该物理端口配置的是什么
VLAN,就只允许这个 Access VLAN 通过;而 Trucck VLAN
一般是作为与其他交换机的汇聚使用的,Trunk VLAN 可以标记 tag
信息,一般只允许打了 tag 信息的 VLAN 通过,所以 Trunk 可以允许多个打了
tag 信息的受到许可的 VLAN 通过。而 Trunk VLAN
和虚拟化结合使用可以实现很多功能。

Hyper-V 的 VLAN 仅在虚拟交换机所对应的物理网卡之上联端口是 Trunk
时方可正常工作。Hyper-V 虚拟交换机并不参与路由,所有 VLAN
的通信完全依赖局域网中的物理交换机所设定的规则来完成。

 

4.2.2
典型应用

财务部门将一台位于 VLAN44
的物理机迁移到了虚拟化平台上,部门领导要求迁移后的虚拟机依然保留之前的网络限制策略,因此在完成迁移后,首先保证连接虚拟交换机的物理端口为
Trunk,然后修改"财务用服务器"这台虚拟机的属性,依次打开虚拟机的"属性"
→"网络适配器"→"虚拟 VLAN 标识",输入 44 即可,如图 4-14
所示。经过配置后,该虚拟机可以继承物理交换机配置的一切 VLAN 属性。

vns威尼斯城官网登入 19 图 4-14 启用 VLAN 标识

如果没有网卡配置为 Trunk 上联口的物理环境,则配置 VLAN ID
无法发挥定义网络通信策略的功效,仅能做到不同 VLAN ID
之间的通信完全阻断。依据这种特性,也可以在测试环境中为部分虚拟机配置不存在的
VLAN ID 来简单的为几组虚拟机实现网络隔离,如图 4-15 所示。

vns威尼斯城官网登入 20 图 4-15 利用 VLAN
ID,简单对测试环境进行隔离

同时,欢迎您加入
"开放讨论群-SDS&虚拟化"
微信群,并邀请其他对SDS和虚拟化感兴趣的朋友加入此微信群。可以通过添加如下管理员之一的微信号,建议添加管理员时,告知你的公司名和姓名,方便备注保存。

然而,硬件、固件、驱动以及操作系统之间的相互关系可能很薄弱且易于出错。有时可能会导致意想不到的新问题或者bug,因此固件以及驱动升级很可能会导致更多的问题。因此不应该盲目升级。

vns威尼斯城官网登入 21

  有的读者可能会问,为什么这三种方式中都没有采用iSCSI存储连接的交换机?

4.4NIC 组合

 

4.4.1
什么是 NIC 组合

NIC 组合即 NIC Teaming,也有被称为"网卡绑定",此技术是 Windows Server
2012/2012 R2
的内置功能,可以为用户提供具有冗余和容错功能的网络适配器,NIC
组合允许一次性绑定最多 32
个网卡接口成一个逻辑组,供用户使用。当组中某一个网卡发生故障时,组合中依然存活的网卡还可以正常使用。值得称道的是,NIC
组合技术对网卡厂商没有硬性要求,这是一种通用的技术。并且在特定前提下,NIC
组合还可以实现带宽叠加的效果。

实现 NIC 组合需要满足以下条件:

  • 至少一个网卡接口,为了实现冗余特性,至少需要链各个网卡接口。
  • 组合接口需要处于同一个网络环境中,如果上联交换机采用的是 Access
    VLAN,则接口需要处于同一个 Access VLAN 中。
  • 组合网卡接口不可超过 32
    个。

NIC
组合拥有如下成组模式:

  • 静态成组,这是一个静态配置的解决方案,这种模式通常需要较高级别的交换机支持,如果插入配置错误的交换机,可能会导致成组失败。
  • 交换机独立,由于交换机不知道网卡接口是某一个 NIC 组合的一部分,因此
    NIC
    组合中的网卡可以连接到不同的交换机上,同时这种方式也是对交换机依赖最小的模式。
  • LACP,链路聚合控制协议(LACP)用来动态的识别计算机和特定交换机之间的关系,一般来说这项技术主要用在交换机和交换机之间,用来带宽叠加,但现在已经可以在
    Windows Server 2012/2012
    R2 上使用了。
注:lacp需要接入的是同一个交换机的2个不同端口,不能接入2台不同的交换机,我直接用我的cisco交换机来测试的。

NIC
组合拥有如下负载平衡模式:

  • 地址哈希,该算法会根据数据包的组成部分哈希,然后将其分配给具有该散列值的可用网卡。这就可以保证相同的数据流能够流向相同的网卡。可以用作哈希的组成部分包括源和目的的
    MAC
    地址、源和目的的 IP
    地址,源和目的的 TCP 端口,
  • Hyper-V
    端口,当虚拟机都具有独立的 MAC 地址时,虚拟机的
    MAC
    地址可以为流量分配提供依据,因为虚拟机的 MAC
    地址是有规律的,交换机可以平衡负载到多条链路上,这个特性和"虚拟机队列"组合使用是非常有用的。值得注意的是,

    Windows Server 2012/2012
    R2 中使用 Hyper-V
    的交换机端口作为识别符,而不是用MAC
    地址,因为在某些情况下,一台虚拟机可能会使用多个 MAC 地址。

  • 动态,该选项类似于"自动",也被称为智能负载均衡或自适应负载均衡。

     

 

4.4.2NIC
组合基本配置

 

第 1 步,打开服务器管理器,点击左侧的本地服务器,在右侧找到 NIC
组合,点击

"已禁用"字样,如图 4-22 所示。

vns威尼斯城官网登入 22 图 4-22NIC 组合配置 1

第 2 步,启动"NIC
组合",在"适配器和端口"对话框,选中未被使用的网卡接口,本例中为"以太网
2"、"以太网 3",如图 4-23 所示。

 

vns威尼斯城官网登入 23 图 4-23NIC 组合配置 2

第 3 步,在"适配器和端口"对话框中,点击"任务",选择添加到新组,如图 4-24
所示。

vns威尼斯城官网登入 24 图 4-24NIC 组合配置 3

第 4
步,在"新建组"对话框中,输入容易记忆的组名称,点击"确定"后返回上一级菜单,完成
NIC 组合配置,如图 4-25 所示。

vns威尼斯城官网登入 25 图 4-25NIC 组合配置 4

第 5 步,在"组"对话框中,可以看到刚才创建的 NIC
组合的状态是"错误",错误原因在"适配器和接口"中有所显示,原因均为媒体已断开连接,即未插入网线。如图
4-26 所示。

vns威尼斯城官网登入 26 图 4-26NIC 组合配置 5

第 6 步,在"组"对话框中,右键点击已创建的组合,选择"属性",如图 4-27
所示。

vns威尼斯城官网登入 27 图 4-27NIC 组合配置 6

vSAN是一种基于软件的分布式存储解决方案,可在任何标准X86服务器上运行,只要I/O
Controller(控制器)、SSD和HDD在vSAN HCL
(Hardware Compatibility List- 兼容列表)内,就可运行。vSAN的HCL非常丰富,为用户的选型提供了非常高的灵活性。

计算设备通常使用堆栈模式构建:硬件(芯片及连接)在底层,固件(比如BIOS)用于初始化并配置硬件,固件使用驱动与操作系统建立连接。bug以及固件或者驱动的编码技术不过关可能会带来性能问题。这种情况要比你想象的多,往往可以通过升级固件以及驱动来解决该问题。

网络资源及配置对虚拟机性能具有重大影响。因此IT专业人员应该考虑带宽、接口类型、驱动以及其他因素。但在复杂的网络环境中相互关系错综复杂,调整网络配置可能会遇到问题。在做出任何调整之前进行基准测试,每次只调整一个因素,然后建立新的性能基准对网络变更带来的影响进行评估。这样做能够帮助识别并解决未预料到的结果,客观地认识配置变更所带来的影响。

  后两种方式都需要在主机上安装专门的硬件板卡,由于目前TOE网卡和iSCSI
HBA的市场价格都比较贵。如果网络中主机数量比较多,那么网络总资金投入不见得会比FC-SAN存储系统低很多,网络的带宽和性能却相比FC-SAN存储系统差了很多。

4.3 带宽管理和网络高级功能

4.3.1
带宽管理

自 Windows Server 2012 起,微软为 Hyper-V
的网卡提供了带宽管理属性,通过带宽管理,可以对虚拟机网卡的流量进行限制,以达到区分服务级别的目的。

开启带宽管理功能非常简单,依次打开虚拟机的"属性"→"网络适配器"→"启用带宽管理",输入最大带宽和最小带宽即可,如图
4-16 所示。此处单位为 Mbps,最小值为

10Mbps,即限制每秒数据流量为 1.25MB。最大值可根据需求进行设置。

需要注意的是,如果希望最大值小于 10Mbps,则最小值只能设置为
0,即不限制最小带宽。

vns威尼斯城官网登入 28

10G网卡双向流量测试结果:

其次,应用到生产系统前要在实验环境中进行升级测试。测试有助于提高升级效率,识别潜在的结果并避免在生产环境中出现潜在的混乱局面。

网卡绑定给虚拟服务器带来了很多好处。绑定允许同一台服务器上的多个网卡适配器协同工作以聚合带宽并进行流量的故障切换。例如,可以绑定两个独立的千兆以太网端口以提供两倍带宽,在单个端口发生故障时也能够确保数据正常传输。

iSCSI设备的主机接口一般默认都是IP接口,可以直接与以太网络交换机和iSCSI交换机连接,形成一个存储区域网络。根据主机端HBA卡、网络交换机的不同,iSCSI设备与主机之间有三种连接方式。

图 4-5 虚拟交换机的配置信息被清空

分别查看"VM"和"vEthernet(VM虚拟交换机)"
两张网卡的"属性",可以发现"VM"
仅自动勾选了"Hyper-V 可扩展的虚拟交换机",而"vEthernet(VM虚拟交换机)"则勾选了 Microsoft
网络客户端、Microsoft 网络的文件和打印机共享、QoS
数据包计划程序、链路层拓扑发现映射器 I/O
驱动程序、链路层拓扑发现响应程序、Internet 协议版本 6、Internet 协议版本
4,和之前的"VM"网卡完全一致,如图
4-6 所示。

 

vns威尼斯城官网登入 29

2.      TCP/IP
虽然没有RDMA网络速度快,但是依然是一个非常可靠的选择
,在对时延要求较低的应用当中,依然可以提供非常可观IOPS输出。

标准的网络依赖于动态主机配置协议给网络客户端动态分配IP地址,DHCP依赖于可用的DHCP服务器。在传统的网络中,找不到DHCP服务器将无法为新设备自动分配IP地址,一旦IP租约到期将无法连接现有的设备。即使是找不到DHCP服务器,自动的私有IP寻址(APIPA)也能使DHCP客户端获得IP地址以及子网掩码。默认情况下,APIPA将使用预留的IP地址,范围从169.254.0.1到169.254.255.254,子网掩码是255.255.0.0。APIPA每几分钟就会检查DHCP服务器,当DHCP服务可用时就将控制权移交给DHCP。一般来说,APIPA主要用于有较少客户端的小型组织,因此运行Hyper-V的Windows服务器平台通常会禁用APIPA。企业级数据中心将采用冗余的DHCP服务器以确保DHCP服务稳定运行。

虚拟化及整合关注于核心的计算资源像处理器、存储以及存储,但是网络I/O资源经常被忽略。网络带宽以及设备配置对确保客户端/服务器高效运行同样很重要——尤其是现在与网络相关的技术在服务器以及网络适配器中不断涌现出来。让我们了解一些能够提升Hyper-V网络性能的技巧。

  第一种方式由于采用普通以太网卡和以太网交换机,无需额外配置适配器,或专用的网络设备,因此硬件成本最低。但由于进行ISCSI包文和TCP/IP包文的打包和解包全部需要主机主处理器CPU来进行运算,数据传输率直接受到主机当前运行状态和可用资源的影响和限制,因此一般无法提供高带宽和高IOPS性能。

图 4-10 创建新的内部网络虚拟交换机

和创建外部网络虚拟交换机一致,创建内部网络虚拟交换机一样会产生一张新的网卡,可以单独配置
IP 地址进行管理,如图 4-11 所示。

vns威尼斯城官网登入 30 图 4-11
内部虚拟网络交换机的新网卡

此时在虚拟机的属性设置选项卡,即可于"网络适配器"→"虚拟交换机"处进行修改,通过下拉菜单选择已创建的虚拟交换机,从最终使用用户角度来看,用户并不能分辨出该虚拟交换机是内部网络的还是外部网络的,如图
4-12 所示。

vns威尼斯城官网登入 31 图 4-11
内部虚拟网络交换机的分配

内部网络虚拟交换机只能完成物理机与虚拟机、虚拟机与虚拟机之间的通信,无法完成虚拟机至其他物理机的通信。因此主要是在一些实验环境中使用。

4.1.3
创建专用虚拟交换机

在虚拟交换机管理选项卡,创建一个新的专用网络虚拟交换机,如图 4-12
所示,专用网络虚拟交换机仅在本物理机上虚拟机之间进行通信,创建个数不受限制。专用网络虚拟交换机不与网卡绑定,无需进行网卡选择,并且由于不与物理机通信,因此不会也不需要创建新的虚拟网卡。

vns威尼斯城官网登入 32

图 4-12
专用虚拟网络交换机由于专用虚拟网络交换机无法与任何外部主机通信,因此其实际应用场景仅限于部分测试环境,如导出线上服务器的数据,在专用虚拟网中进行测试、排错。

4.1.3
删除虚拟交换机

删除外部网络、内部网路、专用网络的虚拟交换机的操作均一致,在虚拟交换机管理选项卡中,检查左侧的虚拟交换机列表,单击需要删除的虚拟交换机,并点击右侧的"移除"
按钮即可。点击"移除"后,左侧被先选中的虚拟交换机会以附带下划线的方式显示,继续点击"确认"或"应用"即可完成删除,如图
4-13 所示。如果删除的是外部网络虚拟交换机,则有可能会有短暂的网络中断。

vns威尼斯城官网登入 33 图 4-13 删除虚拟网络交换机

如果出现如图 4-14
的错误提示,则说明该虚拟交换机已分配给某台虚拟机,当这台涉及的虚拟机没有选择其他虚拟交换机时,该虚拟交换机不可被删除。

vns威尼斯城官网登入 34 图 4-13
删除虚拟网络交换机容易出现的错误提示

vns威尼斯城官网登入 35

虚拟机队列(VMQ)是Intel提供的网络硬件技术,旨在允许网络接口卡使用直接内存访问将内部帧直接传送到网卡的接收缓冲区。这样减少了对基于驱动器的流量交换的依赖性,提升了常见网络流量类型(包括TCP/IP、iSCSI、FCoE)传送到虚拟主机系统的效率。部分改进是由于不同的处理能够处理不同虚拟机的数据包—而不是一个处理器处理所有的网络数据交换。在大多数情况下,应该启用网卡上的VMQ,处理器还应该与外部的交换机进行绑定。

然而,不建议在iSCSI存储流量中采用网卡绑定。在Windows Server
2012及后续系统中建议优先采用多路径I/O也就是MPIO技术来处理iSCSI存储流量。

  与第一种方式相比,采用TOE卡可以大幅度提高数据的传输速率。TCP/IP协议栈功能由TOE卡完成,而iSCSI层的功能仍旧由主机来完成。

在搭建虚拟化平台时,网络的虚拟化是一个非常重要的环节,如何保障网络的持续可用并且可管理,Hyper-V
为此提供了一系列的功能来实现这个目标。网络虚拟化的完善程度,对整个虚拟化平台的扩展性起着非常重要的作用。

 

网络资源及配置对虚拟机性能具有重大影响。因此IT专业人员应该考虑带宽、接口类型、驱动以及其他因素。但在复杂的网络环境中相互关系错综复杂,调整网络配置可能会遇到问题。在做出任何调整之前进行基准测试,每次只调整一个因素,然后建立新的性能基准对网络变更带来的影响进行评估。这样做能够帮助识别并解决未预料到的结果,客观地认识配置变更所带来的影响。

针对虚拟服务器另一个流行的配置是在传输集群共享卷、iSCSI以及在线迁移流量的网络中启用巨型帧。巨型帧数据包大小是9000或9014个字节,而不是常见的1500字节。通过在每个数据包中传输更多的数据,能够通过更少的数据包完成文件传输,网卡和主机系统的效率会提升。然而巨型帧同样意味着两端所有的网络元素(网卡、交换机以及SAN)都要支持巨型帧。

  这种方式由于采用普通的标准以太网卡和以太网交换机,无需额外配置适配器,因此硬件成本最低。缺点是进行ISCSI存储连接中包文和TCP/IP包文转换要点主机端的一部分资源。不过在低I/O和低带宽性能要求的应用环境中和完全满足数据访问要求。

图 4-36 命令行运行 NIC 组合工具 1

如果希望一次对多台服务器(同一域内)配置 NIC 组合,可以使用"lbfoadmin

/servers servername1 servername2 …"这条命令来实现,如图 4-37 所示。

vns威尼斯城官网登入 36 图 4-37 命令行运行 NIC 组合工具

目前vSAN 暂不支持以太网RDMA,不过相信不久的将来会支持。微软曾经提供过一个简单虚拟化环境下RDMA和普通TCP/IP网络性能的对比:

通过在硬件而不是在驱动器或者软件中实现整个TCP/IP协议栈,TCP卸载引擎旨在提升网络性能,减少了准备、形成、传输、接收、解包并收集网络数据包所需要进行的处理工作。TCP烟囱卸载类似,控制权仍保留在操作系统中但实际的数据交换在网卡中进行。一般来说,尽管基于软件的NIC绑定可能不支持卸载硬件,但可以在虚拟系统中启用卸载特性。如果虚拟服务器使用了网卡绑定,那么可以禁用卸载特性,否则通常应该启用卸载特性。

标准的网络依赖于动态主机配置协议给网络客户端动态分配IP地址,DHCP依赖于可用的DHCP服务器。在传统的网络中,找不到DHCP服务器将无法为新设备自动分配IP地址,一旦IP租约到期将无法连接现有的设备。即使是找不到DHCP服务器,自动的私有IP寻址(APIPA)也能使DHCP客户端获得IP地址以及子网掩码。默认情况下,APIPA将使用预留的IP地址,范围从169.254.0.1到169.254.255.254,子网掩码是255.255.0.0。APIPA每几分钟就会检查DHCP服务器,当DHCP服务可用时就将控制权移交给DHCP。一般来说,APIPA主要用于有较少客户端的小型组织,因此运行Hyper-V的Windows服务器平台通常会禁用APIPA。企业级数据中心将采用冗余的DHCP服务器以确保DHCP服务稳定运行。

  安装Initiator软件后,Initiator软件可以将以太网卡虚拟为iSCSI卡,接受和发送iSCSI数据报文,从而实现主机和iSCSI设备之间的iSCSI协议和TCP/IP协议传输功能。

尼玛的我不高兴写了,所以下面的文档我直接把原来的pdf给转换出来,加了点自己的注解,我写的话会写自己觉得终于的章节。

实验拓扑请参考下图:

转载本站文章请注明出处:vns威尼斯城官网登入 http://www.tiec-ccpittj.com/?p=2279

上一篇:

下一篇:

相关文章